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Prius 2007 Toyota 664 AWS 
Escape 2008 Ford Hybrid 712 AWS (Ben’s) 
Sierra 2007 GMC 6429KR (Brenda’s) 
Sierra 2007 GMC 1723KT (Kristen’s) 

 

APPENDIX A – Prince George Mobile Monitoring Protocols 
 

(Adapted from Gail Millar’s Protocol for Mobile Monitoring in the Bulkley Valley) 
 
1. List of Equipement. 
-GPS with Datalogger and screwdriver 
-Folder with Nephelometer Sampling Sheets and pen 
-Power inverter 
-Nephelometer with power cord and 9pin cord to attach to laptop 
-Laptop with power cord 
-Book of routes and maps 
2. Pre and Post Departure Preparation 
1.  E-mail Peter Jackson with the names of the research assistants who will be monitoring 
and the area(s) being monitored (Jennifer). 
2.  Call the RCMP 250-561-3300 with a description of the vehicle, liscence plate number, 
and the areas of town which will being monitored. 
3. 
 
 
 
 
4.  Set the nephelometer clocks to UTC (adapted from Larson et al., 2005) 
The nephelometer clocks must be set to UTC so that the two nephelometers and GPS unit are 
synchronized. 
a. On nephelometer menu: 
i. Press ‘Enter’ button 
ii. Scroll down to ‘Adjust clock’. 
iii. Press ‘Select’ button 
b. Set the date to match UTC date shown on the laptop (pre-set to UTC time) 
c. Set the time to match the upcoming UTC minute on the laptop. 
d. Once appropriate date and time have been selected, scroll down to ‘Save Time ->’ 
e. Press the ‘Enter’ button the instant that UTC time (on the NIST 
website) reaches the appropriate minute. The screen will display: “Setting 
Clock”. 
f. Verify that the nephelometer clocks have been synchronized to UTC 
time by comparing the time on the main display screen of the 
nephelometers and the laptop. 
5. a.  Set up the nephelometer so that the inlet tube is outside the window and the funnel faces 
towards the back of the vehilcle. 
b.  Set up the GPS with the receiver (magnet)  outside the vehicle.  Plug the GPS into the 
cigarette lighter. 
c. Set up the power inverter and attach the nephelometer power cord between the nephelometer 
and the power 
inverter. 
d. Set up the laptop.  Plug one end of the laptop power cord into the laptop. 
e. Turn on the laptop. Open the HyperTerminal program (Start � Accessories � 
Communications). f. The “Connection Description” screen in will appear. Type in 
today’s date abd press ok. 
g. One the next screen (Figure A 6), you will be prompted for the information on the serial 
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port location. Select Com 1 for the black laptop or Com 4 for the silver laptop.  The other 
information on the screen does not apply. Click OK. 
h. The ‘COM Properties’ screen will then appear. Select: Bits per second: 9600, Data bits: 8, 
Parity: None, Stop bits: 
1 and Flow Control: Hardware. Click Ok. 
i. A blank screen will appear. Select ‘Transfer’ (from the HyperTerminal menu) then 
‘Capture Text to File’. The program will ask you the name and location of the text file 
that will be created (this is the data file that the nephelometer measurements will be saved 
to). Select Browse and save the file as: 
C:/Today’sDate_MonitoringLocation.txt  
Click Start. 
j. Start the vehicle 
k. Turn the power inverter on. 
l. Once the power inverter’s light is green, flip the switch for the gps and turn the nephelometer 
on at the same time. 
m. Plug the laptop into the power inverter once the light on the power inverter is green again. 
n. Drive the predetermined route using the navigation instructions and maps. 
Residential streets should be driven at 30km/h.  Non residential areas (with no houses) can be 
driven at the normal 
speeds for the area.  Areas where houses are particularly sparse (i.e. some parts of the Hart, 
North Nechako area etc.. can be driven at normal vehicle speeds.) 
While driving, have the navigator make observations of conditions that may affect data 
(e.g. if area has heavy wood smoke, if a train passed by etc.) by: a) pressing the event 
button on the GPS datalogger and b) making a note of the condition associated with each event 
on the Mobile 
Monitoring Sampling Sheet 
o. At least one residential block needs to be repeated at both the beginning and 
end of the route. p. At the end of the trip, turn the power off on the 
nephelometer and GPS at the same time. 
q. Turn the power off on the nephelometer and undo the setup 
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APPENDIX B – Mobile Monitoring Sampling Sheet 
 

Start Date and Time: End Point and Time: Research Assistant 1: 
Route/Division: Starting Point: Research Assistant 2: 
Datalogger: sticker/no sticker Power Inverter: black/pink Nephelometer: Mobile/Fixed 
Liscence Plate of Vehicle: Computer: silver/black  

 
 
 

Notetaker Event Place Event Time Event Description 
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APPENDIX C – Maps of the Divisions in Prince George 
 

 
Figure C-1: Map of Prince George’s Division of Hart Highway West 
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Figure C‐2: Map of Prince George’s Division of North Nechako 
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Figure C‐3: Map of Prince George’s Division of North Nechako 
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Figure C‐4: Map of Prince George’s Division of Prince George East 
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Figure C‐5: Map of Prince George’s Division of College Heights 
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Figure C‐6: Map of Prince George’s Division of Cranbrook Hill 
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Figure C‐7: Map of Prince George’s Division of Greater Foothill 
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Figure C‐8: Prince George’s Division of Greater Central Fort George 
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Figure C‐9: Prince George’s Division of Downtown 
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Figure C‐10: Prince George’s Division of Greater South Fort George 
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Figure C‐11: Map of Prince George’s Division of Westwood 
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APPENDIX D – Time Matching Data Processing for Mapping Smoke 
(GPS and Nephelometer Data) 
 
 

Standard Operating Procedure Version 1.1 
 
 

Authors: J. Su, AM Baribeau 
 

1. Data Clean-Up Prior to Processing 
Open each of the raw nephelometer and GPS logger data files, and delete any data outside of the time period 
for which data logging took place. Remember that all records are based on Greenwich Mean Time 
(GMT), so if you sampled on 1/2/2005 starting at 8:30 p.m., your nephelometer and GPS records 
would show that you sampled actually at 1/3/2005 and 4:30 a.m. 

 
10 GPS coordinate system conversion 
Latitude: As the first two digits in the downloaded GPS data are the true latitude degrees, these two digits 
should be extracted first. The remaining two integer digits (unit and ten) and all decimal digits are minutes, not 
degrees. They should be converted to degrees for locating spatial points. Label this latitude column ‘LATTMP’. 

 
For example, if our GPS records a point with latitude of 4916.2478, 49 is the degree of the point and 16.2478 is 
the minutes (not degrees). 49 can be separated by INT(4916.2478/100), and the remaining part is 
4916.2478/100- INT(4916.2478/100) in minutes. The minutes should be converted to decimal degrees and 
added up with the integer degrees. The overall calculation can be expressed by: 

 
LAT = INT(LATTMP/100)+(LATTMP/100-INT(LATTMP/100))*100/60 eq.(1) 

 
Longitude: As the first three digits are the true longitude degrees, these three digits should be extracted first. 
The remaining two integer digits (unit and ten) and all decimal digits are minutes, not degrees. They should also 
be converted to degrees. Another thing is that we are in western hemisphere and longitude degrees should be 
negative values. Label this longitude column ‘LONGTMP’. 

 
LONG = -(INT(LONGTMP/100)+(LONGTMP/100-INT(LONGTMP/100))*100/60) eq.(2) 

 
You now have added a formatted date, time field to your original GPS logger data file (we shall later refer to 
this file as GPS1 – save it as a .xls file). 

 
2. Creating comparable time fields 
In dealing with time-matching, we need to create a field in each of the GPS and Nephelometer downloaded 
data, and these two fields should have common expression of time and date. 

 
Raw GPS data have two fields. One is time and another one is date. We can just add one field and combine 
them together. Be sure to put date in front of time, otherwise we might mix the sequence if a measurement 
crosses midnight. For example, if we have a GPS time of 44159 (hour 4, min 41 and sec 59) and date 60105 
(Jan. 6, 2005), I created a value of 60105.044159 by: 

 
GPSTIME = Date+Time/1000000 eq.(3) 

 
The reason to use decimal is for avoiding possible integer overflow. Name the column of values resulting from 
the calculation of equation (3) above ‘GPSTIME’. 

 
The raw Nephelometer data have in sequence YR, MON, DAY, HR, MIN and SEC in separate fields (label 
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them as such). To be comparable with GPS date/time, a new field can be created in a way similar to: 
 

NEPHTIME = yr+mon*100+day*10000+hr/100+min/10000+sec/1000000 eq. (4) 
 

You now have added a formatted date, time field to your original Nephelometer data file (we shall later refer to 
this file as NEPH1 – save it as a .xls file) . Name the column of values resulting from the calculation of 
equation (4) above ‘NEPHTIME’. 

 
3. Time-matching Macros & Preparation of Resulting Output Files for ArcMAP Plotting 

The macros for time-matching of the two data sets can be run in the macro environment of Excel.  Some 
files need to be created in Excel before running the script, as described below: 

 
A.   Create a file named GPSTIMEmthday#.txt. Copy data from the GPSTIME field created above and 

paste them into the GPSTIMEmthday#.txt. Make sure do not use 1000 separators (,), otherwise one 
data point will be treated as two (if using 16,023.52, then it will be treated as 16 and 23.52 ). 
RECORD THE NUMBER OF ROWS OF GPSTIME DATA (~2800). 

B.   Create another file named NEPHTIMEmthday#.txt. Copy data from the NEPHTIME field created 
above and paste them into the NEPHTIMEmthday#.txt. Also make sure do not use 1000 separators. 
RECORD THE NUMBER OF ROWS OF NEPHTIME DATA (~900). 

C.   Copy the text from the timematching.txt file into a Visual Basic (VB) environment:  in Excel, go to 
“Tools > Macro > Visual Basic Editor. Once you are in the VB Editor, go to Insert > Module. This 
will bring up an empty programming space into which you can copy the text from the 
timematching.txt. 
a. Make the following revisions to the timematching.txt source code: 

• Specify the correct # of rows of NEPHTIME data from B. above in the following line of 
the source code: 

Dim Neph(#rows NEPHTIME, 2) As Double 
 

• Specify the correct # of rows of GPSTIME data from A. above in the following line of the 
source code: 

Dim GPS(#rows GPSTIME) As Double 
 

• Change the # rows also for the NEPHTIME and GPSTIME in the following source code 
lines: 

lngNephRecording = #rows NEPHTIME 
 

lngGPSRecording = #rowsGPSTIME 
 

• Specify where the NEPHTIME and GPSTIME text files are stored, in the following lines of 
the source code (bolded text below indicates example file path, where the user should 
provide a filename&path): 

Open "C:\temp\Tim\NEPHTIME.txt" For Input As #1 
 

Open "C:\temp\Tim\GPSTIME.txt" For Input As #2 
 

• Specify the location where you wish to save the output file that will be created from running 
the VB script, in the following lines of the source code (bolded text below indicates 
example file path where the user should provide a filename&path): 

If (FileObject.FileExists("C:\Temp\Tim\Matches.txt")) Then 
 

Kill ("C:\Temp\Tim\Matches.txt") 
 

End If 
 

'output results 
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Open "C:\Temp\Tim\Matches.txt" For Output As #3 
 

D.   Open or import the specified output file into Excel, and format data to 6 decimal places. The first 
column of the output file is the NEPHTIME and the second the GPSTIME. Add two more columns 

to the NEPH1 (Excel) file created in the section of “Creating comparable time fields”. Copy and paste the 
data derived from the output file into the two new columns just added. 

a. Verify that the first new column (from the output file)  is exactly the same as your 
NEPHTIME field, and that the second new column is the GPSTIME closest to the 
NEPHTIME we are hoping to get. 

b. Check the first and last section of the data to see if there are any time discrepancies beyond 5 
seconds. Remove any rows of data whose GPSTIME and NEPHTIME values are > 
5seconds apart.  2 

c. If you can make sure that the two NEPHTIME columns matches 100%, you can remove 
one of them, but be sure to keep one NEPHTIME and one GPSTIME fields in the NEPH1 
data file for subsequent attribute joining in ArcMAP. 

E.   Save the revised GPS1 and NEPH1 data as dbf files, respectively.  Prior to saving these data, 
however, certain formatting requirements must be verified: 

a. ENSURE THAT all of the GPS and NEPH date+time data columns, as well as 
Nephelometer scattering data (SCAT) are formatted to show 6 decimal places, and that 
the columns containing these data are wide enough to display the number of requested 
decimal places.  (the .dbf files will truncate numerical values if they ‘appear’ as such in 
the parent Excel file, which will cause problems in subsequent attempts to join and process 
data in ArcMAP).The .dbf file will accept only one row of ‘column header titles’.  In 
addition, these titles may only be up to 8 characters long, and some symbols are not 
permitted.  Name the column titles for each of the parameters listed below as suggested, as 
you will have to refer to them in ArcMAP: 

 
GPS .dbf file NEPH .dbf file 

 
GPS time date = GPSTIME NEPH time date = NEPHTIME 

Adjusted longitude value = LONG  Bscat value = SCAT 

Adjusted latitude value = LAT 
 

b. HIGHLIGHT the DATA that you wish to save into the .dbf file. Failing to do so will 
result in a .dbf file containing 65000 rows of data (the max. number of rows permitted 
in any given Excel file).  This will dump a large set of zeros into your ArcMAP plot 
and you will ultimately have to remove these. 

 
5. Plotting Nephelometer & GPS Logger Data in ArcMAP: 

 
F. Use Tools > Add XY data to create a spatial presentation of the GPS data in ArcMap. Once you’ve 

opened the  ‘Add XY data’ dialog box: 
a. Open the GPS1.dbf file that you created in section 4E above by using the file search option 

under the heading ‘Choose a table from the map or browse for another table”. 
G.   In the dialog box, you will also be asked to enter the X and Y coordinates of your data set, which will 

be your LONG and LAT column headings, respectively. Click on ‘OK’. A set of GPS data should 
appear on the screen, representing the route that was driven during the corresponding smokemobile 
data logging session. 

H.   Create a shape file from this layer: right-click on the layer, choose Data > Export Data, and in the 
ensuing dialog box: 

a. Specify: Export ‘all features’; 
b. Choose: ‘Use the same coordinate system as this layer’s source data’ 

 
2  More than 5 seconds discrepancy is created when a Nephelometer is turned on (starting 
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measurements) or off (ending measurements) earlier than the GPS unit. 
 

c. Specify a destination file path and file name under the ‘Output shape file or feature class’ 
line. 

d. Click on ‘YES’ when prompted the following: ‘Do you want to add the exported map to the 
current view?’ 

e. Right-click on the OLD layer, click on ‘Remove’, and you will be left only with this new 
layer. 

I. Then use attribute joining in ArcMap to join the Nephelometer data from the NEPH1.dbf file to the 
current layer. To do this, right-click on the current layer, go to ‘Joins and Relates’ > ‘Join’. 

a. In the ‘Join Data’ dialog box, select the ‘Join attributes from a table’ option. 
b. Under ‘Choose the field in this layer that the join will be based on’, select ‘GPSTIME’. 
c.  Under ‘Choose the table to join to this layer, or choose it from disk’, find & select your 

NEPH1.dbf file created in section 4E above. 
d. Under ‘Choose the field in the table to join the base on’, specify ‘NEPHTIME’. 
e. Click on ‘Advanced’, select “Keep only matching records”. The GPS projection is in 

GCS_North_American_1983 and Datum: D_North_American_1983. 
f. Right-click on the new layer containing the nephelometer data, and select 
g. Create a shape file from this layer: Repeat step H. above. 

 
FORMAT Scattering Data: 

h. Double-click on the NEPH layer, and go to the ‘Symbology’ tab. Under the ‘Show’ heading 
in this dialog box, click on ‘Quantities> Graduated Colors’. 

i. Under the ‘Fields > Value’ heading, enter (select from a drop-down list) the column header 
that you have specified for the SCAT (nephelometer) data. Leave ‘Normalization’ at ‘None’ 
if you do not wish to normalize data. 

j. Under ‘Classification’, enter a value of 3 into the ‘Classes’ box, and then click on ‘Classify’. 
k.  Under ‘Method’, click on ‘Quantiles’ from the drop-down menu. 
l. Click on ‘Apply’. 
m.   Your map will now show up with different shades of a parent colour indicating ‘low, 

medium, high’ SCAT values. 
n. Do a final adjustment of your marker colours by right-clicking on the symbol in the left- 

hand ‘Layers’ section of the screen. The custom is green=low, yellow=medium, and 
red=high. 

6. Adding a Legend and Scale to the Layout View of the Created Map 
 

If you wish to display map graphical output in presentation software, or report-writing software, you will 
have to save your current view to a .jpg file so that it can be easily imported. 

i. To Create a Legend: 
 

a. Go to:  ‘View > Layout View’ 
b. Go to:  ‘Insert > Legend’ 
c. In the subsequent dialog box, you must specify for which layer you wish to include a legend, 

and which attributes of this layer you wish to have displayed in the legend. 
d. Once, you are finished specifying information pertaining to your legend (borders, 

background colour, etc.), click on “Apply’ and/or ‘OK’. At this point, your legend will have 
been inserted into your Layout View. 

e. You can change the size and location of your legend by clicking on it and dragging 
it/resizing it using the cursor. 

ii. To Insert a Scale: 
 

While still in Layout View, 
 

f. Go to:  ‘Insert > Scale Bar’ 
g. Select one of the scale bars displayed on the left-hand side of the dialog box 
h. Click on ‘Properties’, and then under ‘Division Units’, specify ‘Kilometres’. 
i. Click on ‘Apply’, and then ‘OK’, and then the scale will appear on the Layout view. 
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j. You can change the size and location of your scale bar by clicking on it and dragging 
it/resizing it using the cursor. 

 
10.1.1.1.1 iii. Saving the Layout View of your Map as a JPEG File 

a. Go to ‘File > Export Map’. You will be automatically prompted in a dialog box to save the 
file in  .jpg format, with a filename that you specify. 

b.  The file is ready to be imported easily into word processing or presentation software. NOTE 
THAT ONCE YOU HAVE IMPORTED this JPEG file, you will no longer be able to 
EDIT and MAKE CHANGES to it in its new application environment. 
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APPENDIX E – Time Macro 
 

SUB MATCHGPS_NEPH() 
 

DIM NEPH(15089, 2) AS DOUBLE 
DIM GPS(15089) AS DOUBLE 

 
DIM LNGNEPHRECORDING AS LONG 
DIM LNGGPSRECORDING AS LONG 
LNGNEPHRECORDING = 15089 
LNGGPSRECORDING = 15089 

 
DIM I, J AS LONG 

 
OPEN "E:\MOBILE MONITORING C DRIVE\GPS & 

NEPHTIME\NEPHTIMEDEC10.TXT" FOR INPUT AS #1 
OPEN "E:\MOBILE MONITORING C DRIVE\GPS & NEPHTIME\GPSTIMEDEC10.TXT" 

FOR INPUT AS #2 
 

FOR I = 0 TO LNGNEPHRECORDING - 1 
INPUT #1, NEPH(I, 0) 

NEXT I 
CLOSE #1 

 
FOR J = 1 TO LNGGPSRECORDING - 1 

INPUT #2, GPS(J) 
NEXT J 
CLOSE #2 

 
FOR I = 0 TO LNGNEPHRECORDING - 1 

FOR J = 0 TO LNGNEPHRECORDING - 1 
IF NEPH(I, 0) = GPS(J) THEN 

NEPH(I, 1) = GPS(J) 
ELSEIF NEPH(I, 0) < GPS(J) THEN 

IF J > 0 THEN 
IF NEPH(I, 0) > GPS(J - 1) THEN 

IF (ABS(NEPH(I, 0) - GPS(J)) < ABS(NEPH(I, 0) - GPS(J - 1))) THEN 
NEPH(I, 1) = GPS(J) 

ELSE 
NEPH(I, 1) = GPS(J - 1) 

END IF 
END IF 

ELSEIF J = 0 THEN 
NEPH(I, 1) = GPS(J) 

END IF 
ELSE 

IF J < LNGGPSRECORDING - 1 THEN 
IF NEPH(I, 0) < GPS(J + 1) THEN 

IF NEPH(I, 0) < GPS(J + 1) THEN 
IF (ABS(NEPH(I, 0) - GPS(J)) < ABS(NEPH(I, 0) - GPS(J + 1))) THEN 

NEPH(I, 1) = GPS(J) 
ELSE 
NEPH(I, 1) = GPS(J + 1) 

NEPH(I, 1) = GPS(J + 1) 
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END IF 
END IF 

ELSEIF J = LNGGPSRECORDING - 1 THEN 
 

NEPH(I, 1) = GPS(J) 
END IF 

END IF 
END IF 
NEXT J 
NEXT I 

 
DIM FILEOBJECT 
SET FILEOBJECT = CREATEOBJECT("SCRIPTING.FILESYSTEMOBJECT") 

 
IF (FILEOBJECT.FILEEXISTS("E:\MOBILE MONITORING C 

DRIVE\MATCHESDEC10.TXT")) THEN 
KILL ("E:\MOBILE MONITORING C DRIVE\MATCHESDEC10.TXT") 

END IF 
 

'OUTPUT RESULTS 
OPEN "E:\MOBILE MONITORING C DRIVE\MATCHES.TXT" FOR OUTPUT AS #3 

 
FOR I = 0 TO LNGNEPHRECORDING - 1 

FOR J = 0 TO 1 
WRITE #3, FORMAT(NEPH(I, J), "#####.######"); 

NEXT J 
WRITE #3, 

NEXT I 
CLOSE #3 

END SUB 
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APPENDIX F – ACCESS CODE FOR ADJUSTING TEOM DATA 
 

Option Compare Database 

Option Explicit 

Public Function GetIndex(IndexFile As String, key As String) 

'Open the index file and for a given key (Date Hour Minute) return the corresponding row of data 

'Return a blank row if we can't find anything 

Dim nf As Integer 

Dim data As String 

Dim key1 As String 

Dim found As Boolean 

    nf = FreeFile 

    Open IndexFile For Input As #nf 

    found = False 

    While Not EOF(nf) And Not found 

        Line Input #nf, data 

        key1 = Left(data, InStr(data, ",") ‐ 1) 

        If key1 = key Then found = True 

    Wend 

    Close (nf) 

    If found Then 

        GetIndex = data 

    Else 

        GetIndex = "," 

    End If 
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End Function 

Public Sub MakeFile(IndexFile As String, DataFile As String, iOutFile As String) 

'Takes an index file of 1 minute increments and adds it to a data file of 10s increments to create 

'a new 3rd file that merges the two. 

Dim Index As String 

Dim df As Integer 

Dim of As Integer 

Dim key As String 

Dim data As String 

Dim dd As String 

Dim dt As String 

Dim Fields() As String 

    df = 1 

    of = 2 

    Open iOutFile For Output As #of 

    Open DataFile For Input As #df 

    While Not EOF(df) 

        Line Input #df, data 

        key = Left(data, InStr(data, ",") ‐ 1) '2/2/2010 18:02:00 assuming mm/dd/yyyy 

        dd = Left(key, InStr(key, " ") ‐ 1) '2/2/2010 

        dt = Mid(key, InStr(key, " ") + 1, 5) '18:02 

        Fields = Split(dd, "/") 

        key = Fields(2) & "‐" & Right("0" & Fields(0), 2) & "‐" & Right("0" & Fields(1), 2) & " " & dt 'Take the 
date/time from data file and convert to index file format: yyyy‐mm‐dd HH:MM 

        Index = GetIndex(IndexFile, key) 

        Print #of, Index & "," & data 
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    Wend 

    Close (df) 

    Close (of) 

End Sub 
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